Referencing the Package Owner for sending mail

Tran-Hoang HauTran-Hoang Hau Posts: 125Team Automic Specialist ✭✭✭✭
Hello, 
We are using LDAP authentication for logging into ARA. Under Package Owner, within ARA, the format for Package Owner is {Client Number}/{Sign On Name}/{Department}, e.g. 100/AJAORI/MCB. 

How can the package owner be assigned to a variable for sending mail (to the above-mentioned user, for example), knowing that mailbox AJAORI@MCB.LOCAL is valid? 

=> you can create a dynamic properties like "{@deployment_package/system/owner}"
and you can create a prompt set which point to the dynamic properties.
when we set the user, there is a box require for enter user email address, so the system will try to send to that address 



Comments

  • Ajay OriAjay Ori Posts: 13 Rookie
    Thanks for the response.

    We attempted this. However, for automated tasks, the variable has a value AUTOMIC.

    Can you please check?

    Cheers,
    Ajay
  • Tran-Hoang HauTran-Hoang Hau Posts: 125Team Automic Specialist ✭✭✭✭
    Hello Ajay Ori  Could you please show us what you have done ? Variable settings, Dynamic Properties ?

  • Ajay OriAjay Ori Posts: 13 Rookie
  • Ajay OriAjay Ori Posts: 13 Rookie

    Hello Hau,

    Thank you so much for the post.

    I have sent the requested information to community@automic.com, since I am unable to post those here.

    I am reachable at ajay.ori@mcb.mu.

    Cheers,

    Ajay

  • Luu LeLuu Le Community Manager Bellevue, WAPosts: 521 admin
    Hi @Ajay Ori
    I have attached the file here per your request.  I also went and post the image below in the spoiler section below:

    Prompt Set:


    Dynamic Property:

    Assign value in workflow:

    Output from Activation Report:



    For future post, if you would like to post image you can do the following:
    Select the image via the "browse.." OR click on the "Image URL" field and paste your image here.


    If you would like to attach the file or image to the post itself:


  • Tran-Hoang HauTran-Hoang Hau Posts: 125Team Automic Specialist ✭✭✭✭
    edited August 21
    Hi Ajay Ori  May I know which is the exact version of Release Manager you are on ?
    you can simple check the version via AWI

  • Ajay OriAjay Ori Posts: 13 Rookie
  • Tran-Hoang HauTran-Hoang Hau Posts: 125Team Automic Specialist ✭✭✭✭
    Hi Ajay Ori , It may be a bug in Version 7.0.1 (I have same issue like yours in 7.0.1) , however It started to work from 7.0.2  you can see the evaluation worked in my system


  • Ajay OriAjay Ori Posts: 13 Rookie
    Hello Hau,

    Thank you for the feedback.

    Can I upgrade only Release Automation to that version?

    After upgrading to this version, how can I use this to send mail to the developer whose package has an issue? I have configured an error routing CALL.ALARM.NEW.1 in the workflow; see an example hereunder:




    In CALL.ALARM.NEW.1, a dummy recipient has been configured. It sends notifications to a group. A member of latter is then sending it manually to the developer. Would removing that recipient and ensuring that each developer has the proper mail address setup on their profile, send the mail to them?

    Cheers,
    Ajay
  • Ajay OriAjay Ori Posts: 13 Rookie
    Erratum:
    Please read "...I have configured an error routine CALL.ALARM.NEW.1...." instead of  "...I have configured an error routing CALL.ALARM.NEW.1...."
  • Tran-Hoang HauTran-Hoang Hau Posts: 125Team Automic Specialist ✭✭✭✭
    Hello Ajay,

    Sure sure you can update to the version 7.0.2
    For the Notification, you can place the variable in the recipient and the variable you should specific in your Workflow (get value from dynamic properties ), so when the dynamic properties resolve, this variable will have value ( developer package owner), then the developer will get an email 



  • Ajay OriAjay Ori Posts: 13 Rookie
    Hello Hau,

    Thank you for the help. I will upgrade Release Automation to 7.0.2 and test this.

    Cheers,
    Ajay
Sign In or Register to comment.